コンテンツにスキップ

Inkscape

出典: フリー教科書『ウィキブックス(Wikibooks)』
情報技術 > Inkscape
美術 > Inkscape

Inkscapeとは[編集]

Inkscapeとは、Linux、Windows、MacOSXで稼動するドロー系のグラフィックアプリケーションである。ベクトル画像を含むSVGファイルの作成、編集が可能である。本書では主にWindows版のInkscape0.43 および Inkscape1.3 での操作法を説明する。

なお、2023年の現代ではinkscape のバージョン 1.1 以前のものはサポート終了である。これから勉強を始めるなら、この番号以上の新しいバージョンのものが良い。

そもそも1.0未満のバージョンは、正式リリースではないので、1.0のリリースに伴いサポート終了になっている。(ただし、実際には公式サイトで、バージョン 0.9 のものも入手できる。2023年に確認.)

Inkscape Portable のスクリーンショット

なお、古いPCでも動くようにと旧バージョン 0.4系 の ポータブル版 Inkscape が存在する。https://inkscape.org/release/inkscape-0.48.5/windows/32-bit/ Inkscape 0.48.5 - Windows : 32-bit ]

ポータブル版は、USBメモリや外付けHDDなどにもインストールできる。ポータブル版をインストールすると、「 InkscapePortable 」フォルダが作られ、その中に実行ファイル InkscapePortable.exe があるので、それを起動すれば使える。

なお、新しい Windows11 でもポータブル版 Inkscape 0.4系 は動きます(※ 2023年8月13日にwindows11 実機で確認ずみ)。

Inkscapeの特長[編集]

下記のような特長(機能)を持っている。

  • 作図ツール
    • 線(直線・ベジェ曲線・フリーハンド線・カリグラフィ線)
    • 楕円弧(円、円弧、楕円)
    • 四角形(長方形・正方形)/ 多角形(星形)
    • テキスト
    • その他(渦形 / コネクター)
  • 編集
    • オブジェクトの移動、回転、対称化、整列
    • 要素のノードの移動、追加、削除など
    • オブジェクトの連結、
    • レイヤー
    • グループ化
    • クローン
    • テキスト表現(パス上に配置、フレーム内テキスト、カーニング、文字間)
  • その他
    • PNG・JPEG画像などのインポート、エクスポート(ファイル名はデフォルトで「ビットマップ」だが0.4系の昔から bmp 形式は非サポート(ポータブル版で確認)。1.3系でもbmpは非サポートのまま)
    • ビットマップのトレース
    • タブレットのサポート(筆圧)
    • SCRIPTによる拡張
    • XMLエディター

SVGファイルとは[編集]

図2:拡大したPNG画像 図3:拡大したSVG画像

コンピュータで扱われる画像の種類にはビットマップ画像とベクトル画像に大別される。ビットマップ画像というのは画像を色情報を持たせた画素を並べて表現したもので、これに対してベクトル画像は円弧、直線などの要素を位置、色、形態などを指定することにより表現したものである。同じ形状のものをビットマップ画像とベクトル画像で表現した場合には縮小した場合には同じように見える場合であっても拡大表示した場合には図2,3で示すように違いがある。

Inkscapeで扱うSVGファイルとは、Scalable Vector Graphicsを省略したものであり、ベクトル画像を扱うことができるオープン標準であり W3C (World Wide Web Consortium(ワールド・ワイド・ウェブ・コンソーシアム)) が採用している。

インストール方法[編集]

ウィンドウズのレジストリにインストールする通常版と、レジストリにインストールしないで使えるポータブル版がある。

下記の操作手順は、主に通常版をインストール手順の説明である。

どちらにせよ、普通に公式サイトでインストーラ-ダウンロードしてきてから、手元のパソコンでインストーラーを実行すればいい。インストールに必要な容量は数百MBあるので、もし不足してるなら、あらかじめ容量を確保しておく。

手順
  • Inkscapeの公式サイトからダウンロードする。
    • 「Download」などと書かれたボタンを押すと、どのバージョンをダウンロードするかの新規画面が現れるので、その画面内にある選択したいバージョンを選ぶ。
  • ダウンロードしたInkscapeファイル(インストーラー)を実行する。(安全のため、実行中の他のプログラムは終了させると、なお良い。)
    • ライセンス (GNU) の確認をいわれるので、チェックをしてから、「Next」などを選択。
    • インストールさせたいコンポーネントの確認が行われるので、コンポーネントを選ぶ。
    • インストール場所の確認(初期設定ではC:\Program files\Inkscape)=よければInstallを選択。
    • ファイルの展開が始まる。
    • インストール終了表示が出るので、Finishを押すと、インストーラーのウィンドウが自動的に閉じられる。

なお、インストール時の表示は英語となっているが、Inkscapeを実行した際には日本語表示となる(Windowsのコントロールパネルの言語設定を変えれば英語表示となる)。

  • 一部の環境においてインストール中にAdobe SVG Viewerのインストール / アップデート / 使用許諾契約の同意を促されることがある。ユーザにとっては予想外かもしれないが、これは.SVGに対する関連付けが追加されることによって規定のブラウザ側が行っている動作(IE6を規定のブラウザにした、他に.SVGを表示できるソフトの入っていないXPで現象に遭遇)。Adobe SVG Viewerを使用しない(=ブラウザで見ない / 他のプラグインを使う)場合は同意する必要はない。

起動と終了[編集]

起動と終了の方法は他のアプリケーションソフトと同じ。

起動方法[編集]

普通のアプリと同様、実行ファイルへのショートカットをクリックすればいい。

なお、Inkscape1.3系ではインストール時に Inkscape とは別に Inkview というアプリもインストールされることがある。しかし絵を描くのに使うのは通常は Inkscape だけであるので、起動するのは Inkscape だけでよい。

  • デスクトップ上のInkscapeショートカットアイコンをクリック
  • windowsの スタート>プログラム>Inkscape>Inkscape
  • エクスプローラなどで編集対象のファイルを選択し、マウス右クリックにより編集、あるいはInkscapeをクリック
起動すると次項に示すアプリケーションウインドウが開く。

終了方法[編集]

  • アプリケーションウインドウの右上のXボタンをクリック。

または

  • メニューバーから ファイル>終了(閉じる)をクリック。ファイル>終了 でも ファイル>閉じる でも、どちらでも終了できる。

画面の説明[編集]

Inkscape/画面説明 参照。

操作方法[編集]

「ツールボックス」などの用語については図1を参照せよ。

図1
Inkscape 1.3 の場合
※ スクショの都合でウィンドウを縮小して撮影した画像です。

ファイルの操作[編集]

Inkscape/ファイル操作 参照。

オブジェクトの作成[編集]

ベジェ線/直線
Inkscapeで直線(※ここでは、まっすぐの線分の意味)を描くには、ベジエ曲線ツールを使う。ベジエ曲線の詳しい定義はwikipediaを見ていただくとして、本ページ用に簡略に説明すると、針金のようなまっすぐの線分を曲げて作る曲線が「ベジエ曲線」である。曲げる前の状態はまっすぐなので、だからもし直線(まっすぐの線分)を書きたい場合には、ベジエ曲線の曲げる前のまっすぐな状態でツール操作を終了すれば良いだけである。Inkscape1.3の場合、ツールボックスでペンアイコンを選択(あるいはShift+F6キーを押す)。ポータブル版の場合、ベジエ曲線ツールを選ぶ。(なお、ポータブル版のペンっぽいアイコンは後述するカリグラフィなので異なるので注意)
このツールが選択されている場合には、万年筆形のマウスポインタとなっている(1.3系でもポータブル0.4系でも万年筆であることを確認ずみ)。
(※要確認)直線の場合には描きたい線の始点でマウスの左ボタンをクリック、終点としたい位置で再度クリックする。始点を指定後にはステータスバーにマウスポインタの位置に応じて長さ、角度が表示される。コントロールキーを押しながら操作することで15度単位の角度直線を描くことができる。端点の位置をクリックして指定することで連結された直線を描くことができる。なお指定する端点を始点の□に合わせる(赤くなる)ことで閉じた線を描くことができる。
ベジェ線の場合には...
Inkscape1.3 の場合
よく使うものを抜粋。ツールが多すぎて、すべては画面内で説明しきれない。


フリーハンド線
ツールボックスで鉛筆アイコンを選択(あるいはF6キーを押す)。
描きたい個所でマウスの左ボタンをクリックしながらドラッグする。ドラッグ時の軌跡がフリーハンド線となる。このツールが選択されている場合には鉛筆形のマウスポインタとなっている。
カリグラフィック線
Inkscape1.3の場合、ツールボックスでカリグラフィアイコンを選択
※要確認(あるいは Ctrl + F6キーを押す)。
このツールが選択されている場合にはS形のマウスポインタとなっている。操作はフリーハンド線とほぼ同じである。ただカーソルキー(矢印キー)を押すことで幅、角度を変えることができる。


長方形・正方形(矩形(くけい)ツール)
長方形オブジェクトを何度か左クリックすると、丸いハンドル「〇」が出てくるので、それを操作するとカドを丸められる
画面左にあるツールボックスで□アイコンを選択(あるいはF4キーを押す)。
描きたい個所でマウスの右ボタンをクリックしながらドラッグ、ボタンをはなすことで四角形状を描くことができる。このツールが選択されている場合には長方形のマウスポインタとなっている。なおコントロールキーを押しながら操作することで正四角形状とすることができる。またInkscape1.3の場合、描かれた図形は、マウス操作で角の丸みを変えることができる。なお描かれる図形は後述のフィル / ストローク設定の線、塗りのものとなる。

なお、楕円を作りたい場合、下記の円・円弧を伸ばす方法のほかにも、上述の長方形のカドを丸める方法でも楕円を作れる。

円・円弧・扇形
ツールボックスで○アイコンを選択(あるいはF5キーを押す)。
描きたい個所でマウスの右ボタンをクリックしながらドラッグ、ボタンをはなすことで楕円形状を描くことができる。円弧を扇形にも変換できる。このツールが選択されている場合には楕円形のマウスポインタとなっている。なおコントロールキーを押しながら操作することで正円形状とすることができる。またメニューバー下のツールコントロールの設定を変えることにより始点、終点を指定した弧形状を描くことができる。なお描かれる図形は後述のフィル / ストローク設定の線、塗りのものとなる。
円を縦または横に引き延ばすこともできるので、楕円および楕円弧もこのツールボックスで可能。
星・多角形
ツールボックスで☆アイコンを選択(あるいは*キーを押す)。
描きたい個所でマウスの右ボタンをクリックしながらドラッグ、ボタンをはなすことで5角の星形状を描くことができる。このツールが選択されている場合には星形のマウスポインタとなっている。ツールコントロールの設定部で多角形としたり角数を変えたり凹凸度、あるいは角部を丸めたりすることができる。なお描かれる図形は後述のフィル / ストローク設定の線、塗りのものとなる。
螺旋
ツールボックスで渦アイコンを選択(あるいはF9キーを押す)。
描きたい個所でマウスの右ボタンをクリックしながらドラッグ、ボタンをはなすことで螺旋形状を描くことができる。このツールが選択されている場合には渦巻形のマウスポインタとなっている。ツールコントロールの設定部で螺旋の巻き方を変えることができる。なお描かれる図形は後述のフィル / ストローク設定の線、塗りのものとなる。
テキスト
ツールボックスでA形のアイコンを選択(あるいはF8キーを押す)。
このツールが選択されている場合にはA形のマウスポインタとなっている。方法として2つある。
  1. 文字を描きたい個所でマウスの右ボタンをクリックし、キーボードより文字を入力する。パスに沿わせる、フレームに入れるなどの編集が可能(後述)。
  2. 文字を描きたい個所でマウスの右ボタンをクリック、ドラッグしながら範囲を指定し、キーボードより文字を入力する。文字が範囲外となった場合には折り返される。
また、入力バーが文字の前にある場合、「Alt」+「方向キー」でカーニング(字間の調整)ができる。

テキスト[編集]

注意事項 テキストで表示できる文字は、使用しているパソコンにフォントがインストールされている文字のみである。もし、相手のパソコンにフォントがインストールされていない場合、文字をパス化して、SVG図形に変換する必要がある。文字のパス化は不可逆であるので、いったん保存してしまったら戻せない。なので別途、パス化する前のテキストをふくむファイルを自分の手元に保管しておく必要がある。

オブジェクトの編集[編集]

Inkscape1.3の場合
フィル・ストロークに関連する操作をした際などに画面右側にその設定パネルが現れるのが普通
フィルとストローク
画面左下あたりに存在するフィル/ストロークの太さ設定欄が存在する。コマンドバーにある「フィル / ストローク」 (Shift+Ctrl+F) で設定用のダイアログが開き、オブジェクトを選択することで、そのオブジェクトのフィルとストロークの変更ができる。
また、全項目の下部にある「透過性」は色の透過性ではなく、オブジェクト自体のものを指し、色の指定とは独立している。
フィル・ストローク
オブジェクト選択時に画面左側に現れる「フィル/ストローク」パネルで、フィル(塗り)とストロ-ク(輪郭線)の編集を行える。


ポータブル版などでオブジェクト選択時にパネルが現れない場合でも、マウスカーソルをオブジェクトに合わせた状態にして右クリックで「Fill and stroke」を選べば、パネル「Fill and stroke」を出せる(ポータブル版は日本語サポートが悪いので英語のパネル名になる)。
この「フィル/ストローク」パネルで、色の塗り方は、
「なし」(塗りなし)   「フラットカラー」(べた塗り)   「線形グラデーション」   「放射状グラデーション」   「パターン」 
が選択できる。「フラットカラー」はInkscape1.3の最近は「単一色」である。なお、アイコンが表示されるので、名称は暗記しなくてよい。なお、Inkscape 1.2からグラデーションの開始の方法が変わり、1.1までは左側のツールバーのアイコンでグラデーション開始だったが、1.2からはフィルとストロークの標準設定にグラデーションが追加されたので画面左のアイコンが不要になった。従来の左側のグラデーション用アイコンもツールバーに残っているので、好きな方法を選べばいい。
色を指定のほか、透過性(αチャンネル)の指定も行える。
画面左下のアレ
この「フィル/ストローク」パネルを用いなくても、画面左下のステータスバーおよびパレットからも、フィル/ストロークの色の編集を簡易的に行える。このように、色の編集には、いくつかの方式があるので、好きな方式を選べばいい。


ストロークスタイル
線の幅・頂点の処理の仕方、線の先端・中心・終端の形状が選択できる。
実線と多様な点線から、用いる線の選択もできる(数字は、点線の切れ込みなどの位置を示しており、0.0から10.0まで動かすことができる)。
テキストとフォント
Inkscape 1.3 の場合 (再掲)
Inkscape1.3の場合ツールバーにある「A」がテキスト挿入用のツール(「テキストツール」という)であり、これをクリックするとカーソルが「+ A」に変わるので、キャンバス・ページ上の挿入したい場所で左クリックすればいい。「+」の中心点が挿入位置である。
画面上部にあるツールコントロールで、フォントのファミリ(windowsの場合ならMS明朝など)やスタイル(ボールドやイタリックなど)を確認できる。なお、MS明朝は最近は「MS PMincho」という。
スタイルは、normal(そのまま)、Bold(太字)、Italic(斜体)、BoldItalic(太字な斜体)の4つが主流だが、使用しているフォントによってはそれ以下の場合もある。かつては normal ではなくregular だったが、Inkscape 1.3 では標準スタイルは「 normal 」になっている。Inkscape 1.3 ではスタイルは normal , bold, italic, light , heavy などがある。たとえばIPAexgothicの場合、スタイルはNormalのみ。
ポータブル版では、アイコンでボールドまたはイタリックのオン/オフをそれぞれ指定する方式になっている。したがって、normal も regular もポータブル版では見当たらない。なので、例えば MSゴシック をボールド体にして、加えてイタリック体にすることも可能。
(※ 要確認)旧バージョン 0.4 ではコマンドバーにある「テキスト / フォント」 ( Shift + Ctrl + T ) で設定用のダイアログが開く、テキスト (F8) で作成したオブジェクトの編集が出来き、使用するフォントとスタイル、レイアウトの指定が出来る。
レイアウトにある「線の間隔」は意味を取りにくいが、行間を指している。
注意としては、フォントの種類によってはInkscapeで使用できない場合や、スタイルの選択に制限がある場合がある。
また、(日本語フォントが中心であるが)レイアウトで縦書きを使用した場合に、字間が広くなる場合もあり、このときには、横書きのまま一文字ずつ改行をし、中央配置にすることで暫時的に縦書きを実現できる。
画面左下のアレ
テキストの色を変えたい場合、Inkscape1.3 でも ポータブル版0.4系 でも、画面下のステータスバーの左の端に、フィルの色とストロークの色の指定欄があるので、そこで指定すればいい。ストロークの太さも、ほぼ同じ場所で変更可能。
別の方式として、Inkscape 1.3系ならテキスト選択時に画面右側に「フィル/ストローク」パネルが現れるので、こちらのほうからも色を指定できる(ただし1.3系のみ。ポータブル版では不可能)。1.3系なら、ユーザーは好きな方式を選べばいい。もしポータブル版でパレットにない色をテキスト色として選びたい場合、テキスト選択した状態でマウスの右クリックで「Fill and stroke」を選び、パネル「Fill and stroke」で詳細設定をする。


オブジェクトの移動[編集]

オブジェクトをクリックして、図のように矢印の出た状態で、矢印以外のオブジェクトの場所を左クリックしたままドラッグすれば、オブジェクトを移動できる。

あるいは、ツールボックスの左上のほうにある選択ツール(ななめ矢印のアイコン)をクリックしても、上記の矢印と同じモードになるので、これでもオブジェクトをドラッグで移動できる。もし他のツールボックスを使用した後などで、矢印が出ない場合には、選択ツールをクリックすれば矢印が出るので、ドラッグでオブジェクトを移動できるようになる。

オブジェクトの拡大と縮小[編集]

オブジェクトをクリックすると、図のように矢印が上下左右とそのナナメの合計8個でるので、この矢印を左クリックしながらドラッグすれば、拡大縮小できる。

上下の矢印の合計2個は、上下方向だけの拡大縮小を行う(ヨコ方向はそのまま)。

左右の矢印の合計2個は、左右方向だけの拡大縮小を行う(タテ方向はそのまま。

ナナメの矢印は、上下の拡大と左右の拡大を同時に行う。Ctrlキーを押しながらナナメ矢印のドラッグを行うことで、タテ・ヨコの拡大率を同じに維持して変形できる。たとえば縦に1.5倍するときは、Ctrlを押しながらにすれば、横にも1.5倍できる。 要するに、Ctrlキーを押したままドラッグによって、タテ・ヨコ比を維持できる。


シェイプの場合

左側のツールボックスで作ったシェイプ図形の場合、何度かクリックすると、図のように □ や 〇 の形をしたハンドルがいくつか現れる(ツールの種類によってハンドルの位置や個数は異なる)。長方形の場合、この□をドラッグすることでも拡大縮小できる。

なお、□や〇といったシェイプのハンドルが現れない場合、オブジェクトを選択した状態で、そのオブジェクトと同じツールボックスのアイコンをクリックすると、目的のオブジェクトにハンドルが現れることがある。


キー操作[編集]

以降にInkscapeで使用できるショートカットキーを記すが、ツール・ダイアログの呼び出しは各項を参照のこと。なお、ショートカットを使わなくてもボタンのクリックでもinkscapeの通常の利用が可能である。
Ctrl + Z やりなおし Ctrl + C コピー Ctrl + X 切り取り Ctrl + V 貼り付け
また、Ctrlキーを押した状態では、四角形の作成が正方形になる、カリ直線では直線の角度が限定される、オブジェクトの変形では縦横の比を保持したままの変形になるなどの変化がある。
そのほか、Shiftキーを押した状態でクリックを繰り返すことで複数のオブジェクトの選択が出来る(Windowsでは一般にCtrlで行う操作であり注意が必要)。

レイヤーの操作[編集]

いちおうレイヤー機能が存在するが、あまり高性能ではない。 Photoshopのような直感的なレイヤー管理は困難である。

レイヤーは[メニューバー]の[レイヤー]にメニューがあり、新規レイヤーの作成・レイヤーの名称変更・移動のほか削除が出来る。
また、ステータスバーには現在、アクティブ(選択している)なレイヤーが表示され、レイヤーの選択・可視化・不可視化・ロックとロック解除が実行できる。ロックしたレイヤーのオブジェクトは選択が出来なくなり、改変する恐れや位置を変更する恐れがなくなる。

参考文献[編集]

本ページを記述する際、調査のため下記の文献を参照させていただいた.

参考にした動画[編集]

主に2017年以降の動画を参照した。(古すぎる動画を見ても、現バージョンと違い過ぎて意味ないので)

※ 他にも参考にした動画やwebサイトがあるかもしれないが、多すぎたりして編集者が覚えてないので、省略されている場合もあるので、紹介抜けがあってもご容赦を。

※ 2023年9月15日現在、書籍は1冊も参照していない。現状では必要なかったので。(仮に買ってもバージョンが少し古い。編集者がすでに主要な操作を知っている経験者。主要でない操作を紹介するつもりが無い。・・・などの理由で書籍は購入せず。)

※ 「 Wikiを見ずとも、YouTubeを見れば済むのでは? このwikiは不要では?」と思うかもしれないが、しかし実際にYouTubeを見ると、サーバーが不安定やメンテナンスで視聴できない時があったり(重要)、目的の情報をページ内検索できなかったり、・・・などなど、動画特有の欠点もある。

外部リンク[編集]

Wikipedia
Wikipedia
ウィキペディアInkscapeの記事があります。