OpenOffice.org Writer 文字列の操作

出典: フリー教科書『ウィキブックス(Wikibooks)』
移動: 案内検索

OpenOffice.org Writer > 文字列の操作


文字列の操作[編集]

ここでは、基本的な文字の操作について紹介します。フォントや文字サイズの変更など文字ごとの見映えに関わる内容が多く含まれています。

'元に戻す'、'やり直す','繰り返し'の使用[編集]

文書の編集中に誤って必要な文章を消してしまうことがあります。このとき、'編集' > '元に戻す' を実行することで、消去した文章を元に戻すことが出来ます。逆に、必要な編集をした後誤って '元に戻す' を実行してしまった時には、'編集' > 'やり直す' を実行することで、'元に戻す' を取り消すことが出来ます。

'元に戻す' や 'やり直す' は、文章の消去だけでなく、文章の挿入や後に述べるフォントの変更や文字色の変更などに対しても用いることが出来ます。

'繰り返し' は、直前に行なった動作を続けて行なうための機能です。よく似た操作を続けて行なう場合に有効です。'繰り返し' は、'編集' > '繰り返し' によって行なうことが出来ます。

太字、斜体の使用[編集]

太字、斜体は文字を目立たせるための機能です。太字を設定すると選択された文字の線が太くなります。また、斜体を選択すると、文字が斜めになります。

太字、斜体の設定にはいくつかの方法があります。

  1. ツールバー中にある'太字'、'斜体'を用いる方法
  2. '書式' > '文字'を用いる方法

いずれの方法でもまず文字を選択します。次に、ツールバーの方法では、'太字'、もしくは'斜体'というアイコンを用います。これらのアイコンをクリックすることで太字、斜体のオン/オフが切り替わります。'書式'>'文字'の方法では、文字を選択し、先ほどと同様にして'書式'>'文字'のウィンドウを開きます。次に、'フォント'タブを選び、'文字装飾'を選びます。ここでは、太字、斜体などの選択肢が表示されるので適切なものを選びます。

'スペルチェック'機能の使用[編集]

w:スペルチェックは、つづりが間違っている英単語を自動的に見つけ出す機能です。文書中で英単語を書いたとき、英単語のつづりが間違っていると、自動的に英単語の下に赤の波線が入ります。この時、赤の波線がかかった単語をw:右クリックします。すると、英単語の修正候補が示されるので、正しい単語と置き換えます。

'類義語辞典'機能の使用[編集]

日本語版には対応する機能は付属していません。

'文書校正'機能の使用[編集]

'文書校正'は、スペルミスなどの辞書に載っていない単語を探す機能です。残念ながら日本語版の辞書が使われてはいないので、日本語のミスは見つけてはくれません。

文書校正機能を利用するには、'ツール'>'文書校正'か、ツールバーの'文書校正'を利用します。


改ページの挿入[編集]

改ページは強制的に次ページに移る区切りです。文書の途中でページを変えたいときに用います。

改ページの挿入には'挿入'>'任意区切り'を利用します。'任意区切り'を選択するとウィンドウが開かれるので、その中のページ区切りを選択して'OK'を選択します。このとき、挿入したときにカーソルがあった場所がページ区切りとなるので、あらかじめページを区切りたい場所にカーソルを持っていってから'挿入'を用いなくてはなりません。

蛍光ペンの使用[編集]

'切り取り'、'コピー'、'貼り付け'、'形式を選択して貼り付け'の使用[編集]

w:切り取りw:コピーは既に作成されている文字などを写し取り、それらを複製できるようにします。w:貼り付けはコピーした内容を、実際に文書中に挿入する作業です。特に、同じ様な内容を何度も入力する必要があるときには、コピー、貼り付けの手順が威力を発揮します。'形式を選択して貼り付け'は、コピーした内容の一部分だけを取りだして貼り付けを行なうときに用いられます。

切り取り、コピーを行なう前に、切り取り、またはコピーを行ないたい内容を選択します。次に、実際に切り取りかコピーを行ないます。この操作は複数の方法があるので後に述べます。切り取りとコピーはどちらも選択された内容の文書中への貼り付けを可能にします。しかし、切り取りは選択された内容を消去しつつ貼り付けを可能にするのに比べて、コピーは文書中への貼り付けを可能にして、しかも選択された内容を消去せずそのまま残します。そのため、コピーは切り取り+同じ場所での貼り付けと同じ意味を持ちます。これらは目的に応じて適宜使いわけて下さい。

切り取り、コピーが終わったら、コピーした内容を挿入したい場所へカーソルを移動します。カーソルが移動できたら、実際の貼り付けを行ないます。また、書式を標準のものにするなど特殊な操作を行なうときには、'形式を選択して貼り付け'を用います。これらもいくつかの方法があるので、後に述べます。

ここからは切り取り、コピー、貼り付けの方法についてまとめます。切り取り、コピー、貼り付けにはいくつかの方法があります。

  1. '編集'以下のメニューを用いる方法
  2. ツールバーを用いる方法
  3. ショートカットキーを用いる方法
  • '切り取り'の方法
  1. '編集'>'切り取り'を選択します。
  2. ツールバー中の'切り取り'のアイコンをクリックします。
  3. ショートカットキーCtrl+xを利用します。
  • 'コピー'の方法
  1. '編集'>'コピー'を選択します。
  2. ツールバー中の'コピー'のアイコンをクリックします。
  3. ショートカットキーCtrl+cを利用します。
  • '貼り付け'の方法
  1. '編集'>'貼り付け'を選択します。
  2. ツールバー中の'貼り付け'のアイコンをクリックします。
  3. ショートカットキーCtrl+vを利用します。
  • '形式を選択して貼り付け'の方法
  1. '編集'>'形式を選択して貼り付け'を選択します。
  2. ショートカットキーCtrl+Shift+vを利用します。

'書式のコピー/貼り付け'を使って書式をコピー[編集]

'書式のコピー/貼り付け'は、文字の書式だけをコピーする操作です。'書式のコピー/貼り付け'を行なうには、あらかじめコピーしたい書式の文字を選択しておき、ツールバーの'書式のコピー/貼り付け'をクリックします。この時、w:カーソルの絵柄が変化します。次に、書式のコピー先を選択すると書式がコピーされます。

フォントの変更[編集]

w:フォントは、文字の形を指定するデータのことです。フォントを変更することでw:明朝体の文字やw:ゴシック体の文字を使いわけることが出来ます。見出しなどの目立たせたい部分の文字はゴシック体を用いることが多いようです。また、それ以外にも手書風フォントや毛筆風フォントなどが存在し、それらを使いわけることで、よりインパクトのある文書を作ることが出来ます。

フォントの変更にもいくつかの方法があります。

  1. ツールバー中の'フォント'を用いる方法
  2. '書式'>'文字'を用いる方法

いずれの方法でもまず文字を選択します。次に、ツールバーの方法では、'フォント名'というアイコンを用います。ここには、現在選択している文字が用いているフォントが表示されます。アイコンの右のメニューをクリックすると、変更可能なフォントが表示されるのでいずれかのフォントを選択します。'書式'>'文字'の方法では、文字を選択し、先ほどと同様にして'書式'>'文字'のウィンドウを開きます。次に、'フォント'タブを選び、'日本語フォント'の'フォント'を選びます。ここでも用いることが出来るフォントが表示されるので、適当なフォントを選びます。

文字サイズの変更[編集]

文字サイズの変更にはいくつかの方法があります。

  1. ツールバー中にある'フォントサイズの変更'を用いる方法
  2. '書式' > '文字'を用いる方法

最初に、ツールバーを用いる方法を述べます。まず最初に、文字サイズを変更したい文字を選択します。文字の選択は、対応する文字をマウスでドラッグすることで行なうことが出来ます。また、対応する文字上で、Shift+矢印キーを用いることでも文字を選択することが出来ます。選択された文字は、色が反転します。

次に、実際に文字サイズを変更する方法について述べます。ツールバー中にはフォントサイズの変更というアイコンがあります。このアイコンは現在選択されている文字のフォントサイズを表示しています。この値を変更することで、文字サイズを変更することが出来ます。文字サイズは数値が大きいほど大きい文字であり、小さいほど小さい文字になります。

次に、'書式'>'文字'を用いる方法について述べます。まず、先ほどと同様に文字サイズを変更したい文字を選択します。次に、文字を選択したまま、'書式'>'文字'を選びます。このとき、文字の属性を変更するウィンドウが表示されます。文字サイズを変更するには、'フォント'タブを選択し、'日本語フォント'の'大きさ'を選択し、数値を変更します。この数値は先ほどの値と連動しており、どちらを用いても同じ結果が得られます。

検索、置換の利用[編集]

検索はある文字列が文書中にあるかどうかを調べる機能です。何かを書いたことがわかっていても実際に書いた場所がわからない時に用います。置換は、検索に加えて書かれた内容を別の内容で置き換える機能です。文書を書いてから漢字や固有名詞等の間違いに気づいたときなどに威力を発揮します。

検索、置換は'編集'>'検索と置換'から利用することが出来ます。実際にメニューからこれを選択すると、検索のためのウィンドウが開かれます。ウィンドウ内には検索したい文字列と置換したい文字列を書き込む欄があります。

まず、検索の方法を述べます。検索を行なうときには、検索を行ないたい文字列を検索したい文字列のための欄に書きこみます。次に、'検索'ボタンをクリックすると、文書内で対応する文字列が表示されます。

次に、置換の方法を述べます。まず、変更したい文字列を検索で用いた欄に書きこみます。次に、上書きしたい内容を置換したい文字列の欄に書きこみます。次に、'置換'ボタンをクリックします。すると、変更したい文字列の場所に画面が移動します。このとき、変更される文字列は反転しています。次に、もう一度'置換'ボタンをクリックすると、反転していた内容が変更され、画面は次の対応する文字列に移動します。仮に、対応する文字列であったとしても何らかの事情で置き換えを行ないたくないときには、'検索'ボタンをクリックすることで、変更を行なわずに次の候補へ移動することが出来ます。

文字飾りの使用[編集]

Writerではいくつかのw:文字飾りを使用することが出来ます。文字飾りにはw:上付きw:下付きw:中抜き、下線などがあります。これらは、いずれも'書式'>'文字'から利用することが出来ます。ここではそれぞれの効果が'書式'>'文字'のウィンドウ内でどこにあるかを述べます。

  • 上付き

'位置'タブの上付きをマークすることで効果が得られます。

  • 下付き

'位置'タブの下付きをマークすることで効果が得られます。

  • 中抜き

'フォント効果'タブの'中抜き'をマークすることで効果が得られます。

'フォント効果'タブの'影'をマークすることで効果が得られます。

  • 下線

'フォント効果'タブの'下線'をマークすることで効果が得られます。下線には二重線や太線などのいくつかの種類がありますが、これは下線のメニューを選択することで用いることが出来ます。

  • 取り消し線

'フォント効果'タブの'取り消し線'をマークすることで効果が得られます。取り消し線には二重線や太線などのいくつかの種類がありますが、これは削除線のメニューを選択することで用いることが出来ます。

日付と時刻の挿入[編集]

文書を作成した日付や時刻は、パソコン自身が持っている値を用いるようにすれば、入力の手間が省けて便利です。この様な機能を用いるには、'挿入'>'フィールド'を用います。フィールド中には日付、時刻などの選択肢があるので、それらを選択することで現在の時刻や日付を挿入することが出来ます。

フィールドを挿入する際時刻のフォーマットを詳しく指定したい場合があります。その時には、'挿入'>'フィールド'>'その他'を選択します。このときフィールド選択用のウィンドウが開かれるので、'文書'タブを選び'形式'内の時刻や日付を選びます。ここで、'フォーマット'内にいくつかの選択肢が示されるので、使用したいフォーマットを選びます。選択が終わったら'挿入'ボタンをクリックすればフィールドが挿入されます。

記号と特殊文字の挿入[編集]

オートコレクトの使用[編集]

オートコレクトは、 あらかじめ何らかの文字列を定めておき、その文字列が入力された際に、異なった文字列に置き換える機能です。間違えて書いてしまいがちな単語や、長く書くのが面倒な単語に略称をつけるときなどに用いられます。

オートコレクトには、それ以外にも'(英語で)すべての文を大文字で始める'などいくつかの機能があります。ここでは、略称を定める操作について述べます。

略称を定めるには、'ツール'>'オートコレクト'を選択します。ここで、'置換'タブを選択すると、既に定義されている修正案が示されます。新しく略称や修正を加えるには、'置換'タブ中の'入力文字列'と'置換文字列'にそれぞれ置き換え元の文字列と置き換え先の文字列を入力し、'新規作成'ボタンをクリックします。ここで、'OK'ボタンをクリックすると、変更が適用されます。

実際に置き換えを行なうには、入力中に自動的に置き換えを行なわせる方法と'オートフォーマット'を用いる方法の2つがあります。これらを設定するには、'ツール'>'オートコレクト'のウィンドウの、'オプション'タブを選択します。ここで、'オートフォーマット'を利用する場合には、'M'にチェックをつけ、入力中の自動置き換えを利用するときには、'T'を利用します。置換を行なうには、'置換リストを使う'のチェックボックスをチェックする必要があります。変更を適用するときには、'OK'ボタンをクリックします。

オートフォーマットを利用するには、あらかじめ置き換えを行ないたい文字列を入力した後、'書式'>'オートフォーマット'>'適用'を利用します。自動置き換えを利用したいときには、'書式'>'オートフォーマット'>'入力時'にチェックがついた状態で、置き換えを行ないたい文字列を入力し、EnterキーかSpaceキーを押します。